$re = '/(?:[^\d$]|^)(\d+)/m';
$str = '2 burgers and 3 drinks would be $15
The cost of 2 burgers and 3 drinks are $15 test12test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);