// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[^\d$]|^)(\d+)").unwrap();
let string = "2 burgers and 3 drinks would be $15
The cost of 2 burgers and 3 drinks are $15 test12test
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}