using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ger(?!244)[0-9A-f]*";
string input = @"ite123ger223Atok23332ger324err00001ger244ger244ger123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}