$re = '/ger(?!244)[0-9A-f]*/m';
$str = 'ite123ger223Atok23332ger324err00001ger244ger244ger123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);