const regex = /ger(?!244)[0-9A-f]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ger(?!244)[0-9A-f]*', 'gm')
const str = `ite123ger223Atok23332ger324err00001ger244ger244ger123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}