re = /ger(?!244)[0-9A-f]*/m
str = 'ite123ger223Atok23332ger324err00001ger244ger244ger123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end