package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z])([A-Z])`)
var str = `Large AcreageOcean IslandTurn KeyIncome Potential
Ocean IslandSeasonalMainland Lot
Lake IslandSeasonalTurn KeyIncome Potential`
var substitution = "\1,\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}