re = /([a-z])([A-Z])/m
str = 'Large AcreageOcean IslandTurn KeyIncome Potential
Ocean IslandSeasonalMainland Lot
Lake IslandSeasonalTurn KeyIncome Potential'
subst = '\\1,\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result