use strict;
my $str = 'Large AcreageOcean IslandTurn KeyIncome Potential
Ocean IslandSeasonalMainland Lot
Lake IslandSeasonalTurn KeyIncome Potential';
my $regex = qr/([a-z])([A-Z])/mp;
my $subst = '\\1,\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";