$re = '/([a-z])([A-Z])/m';
$str = 'Large AcreageOcean IslandTurn KeyIncome Potential
Ocean IslandSeasonalMainland Lot
Lake IslandSeasonalTurn KeyIncome Potential';
$subst = "\1,\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;