#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=SRC=")(.*?)(?=\")"
Local $sString = " <?xml version="1.0" encoding="utf-8"?>" & @CRLF & _
"<OBJEKT ID="91727">" & @CRLF & _
" " & @CRLF & _
" <PICTURE ID="7">" & @CRLF & _
" <ID>7</ID>" & @CRLF & _
" <PIC><IMG SRC="https://d1.cloudfront.net/00722.jpg" width="610" height="480" BORDER=0></PIC>" & @CRLF & _
" </PICTURE>" & @CRLF & _
" " & @CRLF & _
" <PICTURE ID="11">" & @CRLF & _
" <ID>11</ID>" & @CRLF & _
" <PIC><IMG SRC="https://d1.cloudfront.net/01123.jpg" width="630" height="480" BORDER=0></PIC>" & @CRLF & _
" </PICTURE>" & @CRLF & _
" " & @CRLF & _
" <PICTURE ID="2">" & @CRLF & _
" <ID>2</ID>" & @CRLF & _
" <PIC><IMG SRC="https://d1.cloudfront.net/00224.jpg" width="740" height="480" BORDER=0></PIC>" & @CRLF & _
" </PICTURE>" & @CRLF & _
" " & @CRLF & _
" <PICTURE ID="9">" & @CRLF & _
" <ID>9</ID>" & @CRLF & _
" <PIC><IMG SRC="https://d1.cloudfront.net/00925.jpg" width="940" height="480" BORDER=0></PIC>" & @CRLF & _
" </PICTURE>" & @CRLF & _
" " & @CRLF & _
"</OBJEKT>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")