import Foundation
let pattern = #"(?<=SRC=")(.*?)(?=\")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<?xml version="1.0" encoding="utf-8"?>
<OBJEKT ID="91727">
<PICTURE ID="7">
<ID>7</ID>
<PIC><IMG SRC="https://d1.cloudfront.net/00722.jpg" width="610" height="480" BORDER=0></PIC>
</PICTURE>
<PICTURE ID="11">
<ID>11</ID>
<PIC><IMG SRC="https://d1.cloudfront.net/01123.jpg" width="630" height="480" BORDER=0></PIC>
</PICTURE>
<PICTURE ID="2">
<ID>2</ID>
<PIC><IMG SRC="https://d1.cloudfront.net/00224.jpg" width="740" height="480" BORDER=0></PIC>
</PICTURE>
<PICTURE ID="9">
<ID>9</ID>
<PIC><IMG SRC="https://d1.cloudfront.net/00925.jpg" width="940" height="480" BORDER=0></PIC>
</PICTURE>
</OBJEKT>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)