$re = '/(?<=SRC=")(.*?)(?=\")/m';
$str = ' <?xml version="1.0" encoding="utf-8"?>
<OBJEKT ID="91727">
<PICTURE ID="7">
<ID>7</ID>
<PIC><IMG SRC="https://d1.cloudfront.net/00722.jpg" width="610" height="480" BORDER=0></PIC>
</PICTURE>
<PICTURE ID="11">
<ID>11</ID>
<PIC><IMG SRC="https://d1.cloudfront.net/01123.jpg" width="630" height="480" BORDER=0></PIC>
</PICTURE>
<PICTURE ID="2">
<ID>2</ID>
<PIC><IMG SRC="https://d1.cloudfront.net/00224.jpg" width="740" height="480" BORDER=0></PIC>
</PICTURE>
<PICTURE ID="9">
<ID>9</ID>
<PIC><IMG SRC="https://d1.cloudfront.net/00925.jpg" width="940" height="480" BORDER=0></PIC>
</PICTURE>
</OBJEKT>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);