# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=SRC=\")(.*?)(?=\")"
test_str = (" <?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
"<OBJEKT ID=\"91727\">\n"
" \n"
" <PICTURE ID=\"7\">\n"
" <ID>7</ID>\n"
" <PIC><IMG SRC=\"https://d1.cloudfront.net/00722.jpg\" width=\"610\" height=\"480\" BORDER=0></PIC>\n"
" </PICTURE>\n"
" \n"
" <PICTURE ID=\"11\">\n"
" <ID>11</ID>\n"
" <PIC><IMG SRC=\"https://d1.cloudfront.net/01123.jpg\" width=\"630\" height=\"480\" BORDER=0></PIC>\n"
" </PICTURE>\n"
" \n"
" <PICTURE ID=\"2\">\n"
" <ID>2</ID>\n"
" <PIC><IMG SRC=\"https://d1.cloudfront.net/00224.jpg\" width=\"740\" height=\"480\" BORDER=0></PIC>\n"
" </PICTURE>\n"
" \n"
" <PICTURE ID=\"9\">\n"
" <ID>9</ID>\n"
" <PIC><IMG SRC=\"https://d1.cloudfront.net/00925.jpg\" width=\"940\" height=\"480\" BORDER=0></PIC>\n"
" </PICTURE>\n"
" \n"
"</OBJEKT>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.