# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?>https?:|).+?[:;]//gm;t' <<< "www.yahoo.com:описание1
http://site.ru:описание2
www.site3.org:описание3
http://w3k.biz:описание4
www.yahoo.su:описание5
http://w3k.biz;описание6
www.yahoo.su;описание7"