$re = '/(?>https?:|).+?[:;]/m';
$str = 'www.yahoo.com:описание1
http://site.ru:описание2
www.site3.org:описание3
http://w3k.biz:описание4
www.yahoo.su:описание5
http://w3k.biz;описание6
www.yahoo.su;описание7';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;