use strict;
my $str = 'www.yahoo.com:описание1
http://site.ru:описание2
www.site3.org:описание3
http://w3k.biz:описание4
www.yahoo.su:описание5
http://w3k.biz;описание6
www.yahoo.su;описание7';
my $regex = qr/(?>https?:|).+?[:;]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";