#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?>https?:|).+?[:;]"
Local $sString = "www.yahoo.com:описание1" & @CRLF & _
"http://site.ru:описание2" & @CRLF & _
"www.site3.org:описание3" & @CRLF & _
"http://w3k.biz:описание4" & @CRLF & _
"www.yahoo.su:описание5" & @CRLF & _
"http://w3k.biz;описание6" & @CRLF & _
"www.yahoo.su;описание7"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)