#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<iframe[\s]+?src="(http[s]*:\/\/)?www\.youtube\.com\/embed\/([a-zA-Z0-9-_]{11})[^"]*"[^>]*?><\/iframe>"
Local $sString = "<iframe src="https://www.youtube.com/embed/lfLRV19y6hg?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe src="https://www.youtube.com/embed/3xzCyOdf4Qc?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe src="https://www.youtube.com/embed/JtpT4LLxFv4?disablekb=1&rel=0&showinfo=0" width="780" height="440" frameborder="0" allowfullscreen="allowfullscreen"></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe src="https://www.youtube.com/embed/R6UAHzmxJ_g?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe src="https://www.youtube.com/embed/DIFGObcX9A4?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe src="https://www.youtube.com/embed/HtDEqzAk_48?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe src="https://www.youtube.com/embed/n5GpN1Xa4q0?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")