import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<iframe[\\s]+?src=\"(http[s]*:\\/\\/)?www\\.youtube\\.com\\/embed\\/([a-zA-Z0-9-_]{11})[^\"]*\"[^>]*?><\\/iframe>";
final String string = "<iframe src=\"https://www.youtube.com/embed/lfLRV19y6hg?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/3xzCyOdf4Qc?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/JtpT4LLxFv4?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"440\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/R6UAHzmxJ_g?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/DIFGObcX9A4?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/HtDEqzAk_48?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/n5GpN1Xa4q0?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}