import Foundation
let pattern = #"<iframe[\s]+?src="(http[s]*:\/\/)?www\.youtube\.com\/embed\/([a-zA-Z0-9-_]{11})[^"]*"[^>]*?><\/iframe>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<iframe src="https://www.youtube.com/embed/lfLRV19y6hg?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/3xzCyOdf4Qc?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/JtpT4LLxFv4?disablekb=1&rel=0&showinfo=0" width="780" height="440" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/R6UAHzmxJ_g?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/DIFGObcX9A4?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/HtDEqzAk_48?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/n5GpN1Xa4q0?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)