using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)\/(.+)(.cue)$";
string substitution = @"pushd '$1'\nshnsplit -t %n-%t -o flac -f '$2$3' '$2.flac' && rm -f '$2.flac'\npopd\n";
string input = @"Bryan Adams - 1988 Live! Live! Live!/Bryan Adams - Live! Live! Live!.cue
Bryan Adams - 1993 So Far So Good/Bryan Adams - So Far So Good.cue
Bryan Adams - 2005 Anthology/CD2/Bryan Adams - Anthology CD2.cue
Bryan Adams - 2005 Anthology/CD1/Bryan Adams - Anthology CD1.cue
Bryan Adams - 1988 Hits On Fire/Bryan Adams - Hits On Fire.cue
Bryan Adams - 1997 MTV Unplugged/Bryan Adams - MTV Unplugged.cue";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}