// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+)\/(.+)(.cue)$").unwrap();
let string = "Bryan Adams - 1988 Live! Live! Live!/Bryan Adams - Live! Live! Live!.cue
Bryan Adams - 1993 So Far So Good/Bryan Adams - So Far So Good.cue
Bryan Adams - 2005 Anthology/CD2/Bryan Adams - Anthology CD2.cue
Bryan Adams - 2005 Anthology/CD1/Bryan Adams - Anthology CD1.cue
Bryan Adams - 1988 Hits On Fire/Bryan Adams - Hits On Fire.cue
Bryan Adams - 1997 MTV Unplugged/Bryan Adams - MTV Unplugged.cue";
let substitution = "pushd '$1'\\nshnsplit -t %n-%t -o flac -f '$2$3' '$2.flac' && rm -f '$2.flac'\\npopd\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}