import re
regex = re.compile(r"^(.+)\/(.+)(.cue)$", flags=re.MULTILINE)
test_str = ("Bryan Adams - 1988 Live! Live! Live!/Bryan Adams - Live! Live! Live!.cue\n"
"Bryan Adams - 1993 So Far So Good/Bryan Adams - So Far So Good.cue\n"
"Bryan Adams - 2005 Anthology/CD2/Bryan Adams - Anthology CD2.cue\n"
"Bryan Adams - 2005 Anthology/CD1/Bryan Adams - Anthology CD1.cue\n"
"Bryan Adams - 1988 Hits On Fire/Bryan Adams - Hits On Fire.cue\n"
"Bryan Adams - 1997 MTV Unplugged/Bryan Adams - MTV Unplugged.cue")
subst = "pushd '$1'\\nshnsplit -t %n-%t -o flac -f '$2$3' '$2.flac' && rm -f '$2.flac'\\npopd\\n"
result = regex.sub(subst, test_str)
if result:
print(result)