import Foundation
let pattern = #"^(.+)\/(.+)(.cue)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Bryan Adams - 1988 Live! Live! Live!/Bryan Adams - Live! Live! Live!.cue
Bryan Adams - 1993 So Far So Good/Bryan Adams - So Far So Good.cue
Bryan Adams - 2005 Anthology/CD2/Bryan Adams - Anthology CD2.cue
Bryan Adams - 2005 Anthology/CD1/Bryan Adams - Anthology CD1.cue
Bryan Adams - 1988 Hits On Fire/Bryan Adams - Hits On Fire.cue
Bryan Adams - 1997 MTV Unplugged/Bryan Adams - MTV Unplugged.cue
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"pushd '$1'\nshnsplit -t %n-%t -o flac -f '$2$3' '$2.flac' && rm -f '$2.flac'\npopd\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)