import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[24-Jun-2021\\s13:.+?)\\n\\[\\d\\d";
final String string = "[24-Jun-2021 09:15:24 America/New_York] One line data here\n"
+ "[24-Jun-2021 09:15:27 America/New_York] One line data here\n"
+ "[24-Jun-2021 09:15:31 America/New_York] One line data here\n"
+ "[24-Jun-2021 13:49:21 America/New_York] One line data here\n"
+ "[24-Jun-2021 13:49:27 America/New_York] One line data here\n"
+ "[24-Jun-2021 13:49:27 America/New_York] One line data here\n"
+ "[24-Jun-2021 13:49:28 America/New_York] Start of multi-line data here\n"
+ "multi-line data here\n"
+ "multi-line data here\n"
+ "multi-line data here\n"
+ "multi-line data here\n"
+ "multi-line data here\n"
+ "multi-line data here\n"
+ "end of multi-line data here\n"
+ "[24-Jun-2021 13:51:16 America/New_York] One line data here\n"
+ "[24-Jun-2021 14:51:25 America/New_York] One line data here\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}