use strict;
my $str = '[24-Jun-2021 09:15:24 America/New_York] One line data here
[24-Jun-2021 09:15:27 America/New_York] One line data here
[24-Jun-2021 09:15:31 America/New_York] One line data here
[24-Jun-2021 13:49:21 America/New_York] One line data here
[24-Jun-2021 13:49:27 America/New_York] One line data here
[24-Jun-2021 13:49:27 America/New_York] One line data here
[24-Jun-2021 13:49:28 America/New_York] Start of multi-line data here
multi-line data here
multi-line data here
multi-line data here
multi-line data here
multi-line data here
multi-line data here
end of multi-line data here
[24-Jun-2021 13:51:16 America/New_York] One line data here
[24-Jun-2021 14:51:25 America/New_York] One line data here
';
my $regex = qr/(\[24-Jun-2021\s13:.+?)\n\[\d\d/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}