import Foundation
let pattern = #"(\[24-Jun-2021\s13:.+?)\n\[\d\d"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
[24-Jun-2021 09:15:24 America/New_York] One line data here
[24-Jun-2021 09:15:27 America/New_York] One line data here
[24-Jun-2021 09:15:31 America/New_York] One line data here
[24-Jun-2021 13:49:21 America/New_York] One line data here
[24-Jun-2021 13:49:27 America/New_York] One line data here
[24-Jun-2021 13:49:27 America/New_York] One line data here
[24-Jun-2021 13:49:28 America/New_York] Start of multi-line data here
multi-line data here
multi-line data here
multi-line data here
multi-line data here
multi-line data here
multi-line data here
end of multi-line data here
[24-Jun-2021 13:51:16 America/New_York] One line data here
[24-Jun-2021 14:51:25 America/New_York] One line data here
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)