import re
regex = re.compile(r"(\[24-Jun-2021\s13:.+?)\n\[\d\d", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("[24-Jun-2021 09:15:24 America/New_York] One line data here\n"
"[24-Jun-2021 09:15:27 America/New_York] One line data here\n"
"[24-Jun-2021 09:15:31 America/New_York] One line data here\n"
"[24-Jun-2021 13:49:21 America/New_York] One line data here\n"
"[24-Jun-2021 13:49:27 America/New_York] One line data here\n"
"[24-Jun-2021 13:49:27 America/New_York] One line data here\n"
"[24-Jun-2021 13:49:28 America/New_York] Start of multi-line data here\n"
"multi-line data here\n"
"multi-line data here\n"
"multi-line data here\n"
"multi-line data here\n"
"multi-line data here\n"
"multi-line data here\n"
"end of multi-line data here\n"
"[24-Jun-2021 13:51:16 America/New_York] One line data here\n"
"[24-Jun-2021 14:51:25 America/New_York] One line data here\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")