$re = '/(?<!\\\\)\((\?<(?<name>[\w][\w\d_]+)>|(?=[^\?]))/m';
$str = '(?:(?<=s+)(?<template>Td{1,2})s+|(?<=\\()(?<ptemplate>Td{1,2})|(?:\\b(?<value>v\\d{1,2})\\b(.*)))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);