import re
regex = re.compile(r"(?<!\\)\((\?<(?<name>[\w][\w\d_]+)>|(?=[^\?]))", flags=re.MULTILINE)
test_str = "(?:(?<=s+)(?<template>Td{1,2})s+|(?<=\\()(?<ptemplate>Td{1,2})|(?:\\b(?<value>v\\d{1,2})\\b(.*)))"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")