re = /(?<!\\)\((\?<(?<name>[\w][\w\d_]+)>|(?=[^\?]))/m
str = '(?:(?<=s+)(?<template>Td{1,2})s+|(?<=\\()(?<ptemplate>Td{1,2})|(?:\\b(?<value>v\\d{1,2})\\b(.*)))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end