using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">[^<>]{1,}<HR>";
string input = @"<BR>
<IMG skip>Юзер1<HR>
<BR>
Юзер2<HR>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}