$re = '/>[^<>]{1,}<HR>/s';
$str = '<BR>
<IMG skip>Юзер1<HR>
<BR>
Юзер2<HR>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);