package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)>[^<>]{1,}<HR>`)
var str = `<BR>
<IMG skip>Юзер1<HR>
<BR>
Юзер2<HR>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}