// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)>[^<>]{1,}<HR>").unwrap();
let string = "<BR>
<IMG skip>Юзер1<HR>
<BR>
Юзер2<HR>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}