#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(off|offs|offed|offing|hang|hangs|hanged|hung|hanging|cut|cuted|cuts|cutting)\s+(myself|themself|themselves|oneself|me|himself|herself|yourself)\b"
Local $sString = "I'm overloaded for work, I'd be happy if you took some of it off me."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")