package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(off|offs|offed|offing|hang|hangs|hanged|hung|hanging|cut|cuted|cuts|cutting)\s+(myself|themself|themselves|oneself|me|himself|herself|yourself)\b`)
var str = `I'm overloaded for work, I'd be happy if you took some of it off me.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}