using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b(off|offs|offed|offing|hang|hangs|hanged|hung|hanging|cut|cuted|cuts|cutting)\s+(myself|themself|themselves|oneself|me|himself|herself|yourself)\b";
string input = @"I'm overloaded for work, I'd be happy if you took some of it off me.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}