re = /(?i)\b(off|offs|offed|offing|hang|hangs|hanged|hung|hanging|cut|cuted|cuts|cutting)\s+(myself|themself|themselves|oneself|me|himself|herself|yourself)\b/
str = 'I\'m overloaded for work, I\'d be happy if you took some of it off me.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end