using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\$\{(\b[a-zA-Z0-9]+\b)\})(\[([^]]+)\])";
string input = @"${test}[arg]
${test}[arg1] - ${test2}[arg2]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}