re = /(\$\{(\b[a-zA-Z0-9]+\b)\})(\[([^]]+)\])/m
str = '${test}[arg]
${test}[arg1] - ${test2}[arg2]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end