package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\$\{(\b[a-zA-Z0-9]+\b)\})(\[([^]]+)\])`)
var str = `${test}[arg]
${test}[arg1] - ${test2}[arg2]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}