$re = '/(\$\{(\b[a-zA-Z0-9]+\b)\})(\[([^]]+)\])/m';
$str = '${test}[arg]
${test}[arg1] - ${test2}[arg2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);