using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b\w\b|\G(?!^))\K\h(?=\w\b)";
string substitution = @"";
string input = @"hello world, h e l l o! hi. I am happy to see you!
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}