use strict;
my $str = 'hello world, h e l l o! hi. I am happy to see you!
';
my $regex = qr/(?:\b\w\b|\G(?!^))\K\h(?=\w\b)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";