re = /(?:\b\w\b|\G(?!^))\K\h(?=\w\b)/m
str = 'hello world, h e l l o! hi. I am happy to see you!
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result