$re = '/(?:\b\w\b|\G(?!^))\K\h(?=\w\b)/m';
$str = 'hello world, h e l l o! hi. I am happy to see you!
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;