using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(ABCDEF|FEDCBA|AA-BB-CCCC|ABCDEFGH-IJK)$";
string input = @"ABCDEF
FEDCBA
AA-BB-CCCC
AA-BB-CCCC
ABCDEFGH-IJK";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}