$re = '/^(ABCDEF|FEDCBA|AA-BB-CCCC|ABCDEFGH-IJK)$/m';
$str = 'ABCDEF
FEDCBA
AA-BB-CCCC
AA-BB-CCCC
ABCDEFGH-IJK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);